Nutanix NCS-Core Practice Exams
Last updated on Oct 06,2026- Exam Code: NCS-Core
- Exam Name: Nutanix Certified Services Core Infrastructure Professional
- Certification Provider: Nutanix
- Latest update: Oct 06,2026
An administrator receives an alert in Prism indicating that interface eth2, on an AHV host is receiving
many CRC errors.
After togging into the problematic host, the following command is run to show the indicated output:

What is causing this issue?
- A . Incorrect link speeds on the switch
- B . The interface is incorrectly configured with Jumbo Frames
- C . A misconfigured bond
- D . A physical layer network problem
A customer has a Nutanix cluster with 10Gb connectivity via switch fabric extenders. The administrator receives NCC health check errors of latency greater than 200ms.
Which action should the administrator take to resolve the NCC errors?
- A . Replace the switch fabric extenders with 10G line rate switches
- B . Upgrade NCC and increase the CVM memory by 4Gb
- C . Add 2 additional 10G uplinks from the switch fabric extenders per node
- D . Upgrade NCC and increase the vCPU of the CVM
HOTSPOT
A system administrator needs to shut down an AHV node in a Nutanix cluster without causing service disruption. The administrator checks data resiliency and verifies that the cluster can tolerate a node down.
Which three steps should the administrator perform next? (Choose three.)

An administrator protected a DB VM running on a Nutanix cluster with NearSync Replication, which schedules to repeat every 15 minutes □ to a second site. The daily change rate is low. During nightly backups, the replication window is missed due to write volume.
Which two options describe the expected behavior? (Choose two.)
- A . NearSync stops working and fails over to the remote site.
- B . Protection Domain transitions back to the hourly schedule.
- C . The Administrator needs to re-enable it manually.
- D . The system continuously tries to get to the NearSync schedule.
An administrator deploys Exchange on a Nutanix cluster.
The administrator creates two containers with RF2 configuration:
• One container for Exchange
• One container for the other VMs
The Exchange VM is experiencing I/O performance issues.
Which changes to Storage Optimization should be used on the Exchange container to enhance I/O performance?
- A . No data reduction
- B . Post process Deduplication only
- C . Inline compression and EC-X
- D . Inline compression and Deduplication
An administrator has a custom backup application that requires a 2TB disk and runs in Windows.
Throughput is considerably lower than expected.
The application was installed on a VM with the following configuration:
• Four vCPUs with one core/vCPU
• 4GB of Memory
• One 50GB vDisk for the Windows installation
• One 2TB vDisk for the application
What is the recommended configuration change to improve throughput?
- A . Increase the number of cores per vCPU
- B . Increase the vCPUs assigned to the VM
- C . Span the 2TB disk across four vDisks
- D . Add 4GB of memory to the VM
A customer wants to run SAP HANA on a Nutanix cluster with the following characteristics:
• AHV nodes
• SAP HANA version 2
• Production database files
Which configuration should be recommended to the customer?
- A . Start with a cluster containing three or more nodes
- B . Enable only compression for the container that contains the Production database
- C . Do not enable compression, deduplication. or erasure coding on the storage container
- D . Plate the SAP HANA Database on the same socket as CVM
An administrator is updating disk firmware using LCM and receives the following message:
“there have been 10 or more cluster services restarts within 15 minutes in the Controller VM”
The message appears as each drive is upgraded.
What is the reason this message is being generated?
- A . A node has been rebalanced
- B . A drive has been reformatted
- C . A node has been rebooted
- D . A drive has been ejected
An administrator needs to expand a cluster based on AHV and running on Nutanix G5 hardware with a new Nutanix G7 system. The cluster is running AOS 5.10 but the operation fails when expanding the cluster. AOS is running on the new system. There are no issues discovering the node.
Why is the operation failing?
- A . AOS version running on G7 is older than the version on the cluster.
- B . Foundation software has not been updated on the cluster.
- C . G7 hardware cannot be added to a G5 cluster.
- D . EVC needs to be configured before cluster expansion
An administrator is deploying several new application VMs to a Nutanix cluster. The application is very transactional with a 28/72 random, read/write ratio.
What should the administrator do?
- A . Add a minimum of four SSDs to each node to ensure all writes go to the SSDs.
- B . Add a minimum of four virtual disks to each VM, and aggregate them on guest OS level.
- C . Add one large SSD to each node and enable Flash Mode for the VMs.
- D . Add one large virtual disk to each VM. and use it for all application data.


